Layer 7 DDoS attack
Incident Report for Status for Fathom Analytics
Resolved
The attack on 14th November lasted around 3 hours, and our data collector was up & down, but we didn't want to update this page until we'd finished implementing our new layer of defence.

As we've said in previous updates, we've been the target of a highly motivated, malicious attack that is looking to damage Fathom.

We've made the following changes:

- We now have a 24x7 DDoS attack mitigation team. This a highly specialized team who, in the event of a huge DDoS attack against Fathom, will help us absorb it.
- We have developed a new threat checking system within our application. It's invisible, and works to block perceived attacks that get past our firewall.
- We are going to be building new spam protections using machine learning over the next few months.
- All analytics software gets hit with spam. It's not fun for us or for the handful of our customers who were targeted. However, we are taking this attack as a learning opportunity, and we are now developing an advanced spam protection system that will look to a) prevent spam where possible and b) clean up spam gracefully.

As we've said before, we truly appreciate your patience during these attacks and we're sorry that they're happening.

Identified

We are under attack again. We have actually been under attack for the past week, on and off, and this is a targeted, motivated attack on our service. We have mitigated some spam, which is sent every single hour, but occasionally we are flooded with hundreds of thousands of concurrent requests.

There is not a lot we can do when under this kind of attack but we are working on solutions and will be bringing in a 24/7 DDoS protection service very soon.
Posted Nov 14, 2020 - 00:00 PST