Provider issues
Incident Report for Status for Fathom Analytics
Resolved
What a day. AWS having issues like this, where it actually makes mainstream news, is unbelievably rare. Having said that, it's given us some things to think about. We can't recall an outage with such an impact since 2012. Following this, it's given us a +100 to look into multi-region availability.

Having said that, it looks like our data collector remained available throughout. Early on in the problem, we saw a large queue backlog, but it was quickly handled. And our current visitors continued to work throughout the day. We are currently working through millions of pageviews in our backlog which need to be aggregated into your dashboard stats. The good news is that it seems like we weren't impacted severely.

One final note we'd like to make regarding the pageview backlog. We've had numerous backlogs with pageviews since our inception. We're pleased to share that we are almost ready to move to Elasticsearch, where we'll see no more backlogs and real-time data reporting. This will be a huge win for us and our customers, and we can't wait to have it completed.

Update

Interestingly, since we identified the attack, our pageview collector seems to have been running just fine. Looking at our database, we can see a large backlog of data, and the issue seems to be that pageviews aren't aggregating to your dashboard. Once AWS fixes the problems they're having, the aggregation will resume.

One thing we want to make clear, this has nothing to do with the recent DDoS attacks we were receiving, this is related to a large scale AWS problem. These regional outages are incredibly rare and, unfortunately, we are in a position where we simply have to wait. As we say, we seem to only have been mildly impacted.

Identified

Our service provider is currently having issues and we are looking into it.
Posted Nov 25, 2020 - 10:07 PST