Layer 7 DDoS attacks
Incident Report for Status for Fathom Analytics
Resolved
The attack ended November 7th PT. As we stated before, only 0.01% of customers were hit with spam, but all customers were affected.

The attack was intermittent and typically ran in periods of 3-4 hours at random times of the day, not 24/7.

Our system throttled incoming pageviews in defense, so we didn't collect 100% of page views sent to us. We apologize for the inconvenience here. We can assure you that we did everything within our power to absorb this malicious, unprovoked attack on Fathom.

Moving forward, here is how we are responding to the challenge of spam & Layer 7 DDoS attacks:

We are working with our service providers to see what we can do about this in the future.
We are now building our own spam detection system that will be complete this week. We already rolled out Version 1 of our spam protection system during the attack and mitigated many millions of additional spam pageviews.
We knew that this attack would only lead to Fathom becoming a better analytics product. And that's exactly what is happening right now.
And finally, thank you so much to everyone who has shown us support. Every single person affected has been so understanding during this challenging time and we just want to say thank you. We love building this software for you, and we appreciate all of your patience.

Posted at 7:34pm PT
Update
The attack is back. We have mitigated the majority of the spam but the dashboard it still having intermittent availability issues.

At this moment in time, we're continuing to work on anti-spam measures, introducing new technology in response to the attack.

Update

We haven't updated this until now because we weren't certain that the attack was over. It seems to have stopped today. Less than 0.01% of customers were affected by the spam attack, but we still saw backlogs.

We've had plans to improve the way we process pageviews (to prevent backlogs & improve aggregation speed) for a while now. Following this attack, we've now prioritized these tasks, and will be rolling out the upgrades as soon as they are ready.

Update

We mitigated a large chunk of the attack by using pattern matching. Unfortunately, the attack was done via a botnet, and a lot of the traffic looked legitimate, so there was no kind of blocking we could do. The attack has now stopped.

For those who have been targeted as part of this spam attack, please email us, and we will clear the spam on your account.

One of the big problems we had with this attack was that the floods of traffic lead to issues with the Current Visitors box and the speed of data aggregation. We know that stopping spam is impossible, and all analytics companies are subject to it, but we want to be able to absorb spam traffic without backlogs.

We are now working on a self-serve spam removal tool and rebuilding our aggregation system to ensure backlogs don't occur in the future.

Update

The attack has continued into today. The backlog is still happening and some customers are being hit with large amounts of referral spam. We are still actively working on this issue. Thanks so much again for your patience with this matter.

Identified

Fathom is being targeted by malicious attack, sending tons of referral traffic our way. All customers will experience delays in seeing new traffic show up on their dashboards (but that data is still being collected). We appreciate your patience.

Update

We have mitigated the attack, and are working through our backlog. As this has happened before, we are working on additional protections and backlog defences. If you have any referral spam on your dashboard, let us know and we'll purge it for you. Thanks again for your patience.
Posted Nov 08, 2020 - 00:00 PST