Data delay on dashboards.
Incident Report for Status for Fathom Analytics
Resolved
The backlog has cleared, your stats are fast again.

Identified

There is currently a delay in data appearing on your dashboard. Your data hasn't been lost, it's just delayed. This is due to a customer going viral beyond anything we've seen previously.
Posted Sep 19, 2020 - 00:00 PDT